[さくらレンタル] ruby 1.9.3 と Rails 3.2.2 インストール - suVeneのアレ

[さくらレンタル] ruby 1.9.3 と Rails 3.2.2 インストール

追記1 2012/3/16 01:03

そもそも、Rails はバージョン 2.3 以降から Rack 採用だから、CGI 経由じゃ動かないのか。VPS 借りようかな。
Daisakkkuのblog : さくらインターネット(共用・スタンダード)にRubyOnRailsをインストールしてみた。(その1) はてなブックマーク数
Daisakkkuのblog : さくらインターネット(共用・スタンダード)にRubyOnRailsをインストールしてみた。(その1) はてなブックマーク数

↓ ここから下は「ただインストールしてみました」ってだけとなる↓

初期状態

% ruby -v
ruby 1.8.7 (2011-12-28 patchlevel 357) [i386-freebsd7]

% gem --version
1.6.2

Rubyインストール

まずは、最新版 Ruby のインストールから。

% mkdir -p ~/local/src/
local/src/

% wget ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-rc1.tar.gz

% tar xzvf ruby-1.9.3-rc1.tar.gz
ruby-1.9.3-rc1/

% ./configure --prefix=$HOME/locale
% make && make install

環境設定

export して、version 確認。

% vim ~/.zshenv
export PATH=$HOME/local/lib/ruby/gems:$HOME/local/bin:$HOME/usr/local/bin:$PATH
export RUBYLIB=$HOME/local/lib/ruby/site_ruby/1.9.1:$HOME/local/lib/ruby
export GEM_HOME=$HOME/local/lib/ruby/gems

% source .zshenv
ruby 1.9.3dev (2011-09-23 revision 33323) [i386-freebsd7.1]

% gem -v
/home/zeromemory/local/lib/ruby/1.9.1/yaml.rb:56:in `':
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.

なにやら、libyaml が必要とのことなので、LibYAMLからダウンロード。

% tar xzvf yaml-0.1.4.tar.gz
% yaml-0.1.4.tar.gz
% ./configure --prefix=$HOME/locale
% make && make install

もっかい ruby インストール。 –with-opt-dir 付きで。

[さくらレンタル] ruby 1.9.3 と Rails 3.2.2 インストール
追記1 2012/3/16 01:03 そもそも、Rails はバージョン 2.3 以降から Rack 採用だから、CGI 経由じゃ動か...
% ./configure --prefix=$HOME/local --with-opt-dir=$HOME/local --enable-shared --disable-install-doc --enable-option-checking
% gem --version
1.8.19

最後に Rails インストール

% gem install rails
% rails -v
Rails 3.2.2

おわり。
動作確認はまだしていない。

参考URL

スポンサーリンク
スポンサーリンク

コメント

コメントをどうぞ

メールアドレスが公開されることはありません。